Chcesz udostępnić swoją stronę WWW na Facebook’u i wygenerowany podgląd jest daleki od Twoich oczekiwań? Jeśli używasz WordPressa to nie martw się jest na to proste rozwiązanie. 

Facebook – brak miniaturki udostępnionego wpisu lub strony?

Sprawdź proste rozwiązanie problemu – 4 proste kroki.

1. Wejdź na stronę Sharing Debbuger od Facebook’a

Wprowadź na niej adres URL, z którym masz problem i naciśnij Debuguj. Poniżej zobaczysz informacje, jak wygląda Twój link po udostępnieniu. Wybierz następnie guzik Scrape Again i sprawdź czy podgląd wygląda już dobrze. Jeśli nadal jest problem to przejdź do kolejnego punktu.

facebook-nie-laduje-miniaturki-wpisu-lub-strony-sprawdz-rozwiazanie

2. Zainstaluj i skonfiguruj wtyczkę Yoast SEO

Jeśli korzystasz z WordPress.org to wejdź we Wtyczki, wyszukaj ją, a następnie zainstaluj. Po jej instalacji w menu z lewej strony pojawi się dział SEO, wybierz go, a następnie przejdź do widoku  Społeczności → Facebook → Ustawienia strony głównej

Wybierz tam obrazek, który ma się pojawiać, gdy ktoś udostępnia stronę główną w social media, uzupełnij także tytuł oraz opis.

Dodatkowo w dziale Ustawienia domyślne wybierz obrazek, który ma się pojawiać po udostępnieniu wpisu lub strony, które nie zawierają obrazka wyróżniającego.

yoast-seo-facebook-nie-laduje-miniaturki-wpisu-lub-strony-sprawdz-rozwiazanie

3. Edycja wpisu lub strony

Przejdź do edycji problematycznego wpisu lub strony. Po instalacji wtyczki Yoast SEO pod okienkiem dodawania treści pojawił Ci się panel dodatkowych opcji. Uzupełnienie tych opcji ma wpływ na pozycjonowanie Twojej strony, ale to jest nie temat na dziś.

Aby rozwiązać swój problem przejdź do drugiej zakładki z lewej strony dotyczącej portali społecznościowych. Następnie uzupełnij tytuł, opis oraz dodaj obrazek, który ma się wyświetlać na Facebooku po udostępnieniu.

wtyczka-yoast-seo-facebook-nie-laduje-miniaturki-wpisu-lub-strony-sprawdz-rozwiazanie

4. Wykonaj ponownie krok 1

Przejdź ponownie do Facebook for Developers i wykonaj czynności z punktu 1 jeszcze raz.

Udało się?

Problem powinien być już rozwiązany. W razie, gdyby tak nie było to daj znać w komentarzu lub w grupie na FB. Spróbujemy rozwiązać dla Ciebie indywidualne rozwiązanie.

Inne możliwe problemy

Jeśli jednak nadal masz problemy z miniaturką i opisem swojej strony po udostępnieniu jej na Facebooku. To być może mają na to wpływ inne kwestie.

  • Treść strony nie jest dostępna po wpisaniu hasła i Facebook może nie mieć dostępu do tych informacji
  • Wpis nie jest opublikowany i jest widoczny tylko dla administratora.
  • Tymczasowy problem z serwerem – użyj metody z punktu 1, kiedy problem zostanie naprawiony.

Ola Gościniak

Pomysłodawczyni marki Jestem Interaktywna, ekspertka WordPress, mentorka biznesów online, blogerka, przedsiębiorczyni, wykładowczyni akademicka, autorka e-booków, książek m.in. bestsellerowej „Bądź Online” oraz kursów online WordPress i WooCommerce, organizatorka Interaktywnej Konferencji, autorka cenionego podcastu wyróżnionego przez Forbes Woman. Więcej →

Interaktywna Paczka otwarta!

Otwórz się na inne biznesy, rozwijaj pod okiem ekspertów i pnij się na szczyt biznesowej drabiny. Nabór trwa tylko do 24 stycznia 2023!

35 Komentarze

  • Hm.. Ja jak na razie nie miałam z tym problemów – na szczęście!

    • Zazwyczaj pojawia się taki błąd w przypadku nowych stron – dobrze, że go uniknęłaś 😉

  • A mi czasem ładuje miniaturkę tylko nie tą co trzeba 🙁

    • Jeśli masz WordPressa i wtyczkę Yoast SEO, to nie powinnaś mieć tego problemu. A jeśli jednak zdarza Ci się to rozwiązanie jest w punkcie 3 🙂

  • U mnie zawsze pierwszy sposób pomagał :). Ale dzięki 2 i 3 dowiedziałam się o nowych możliwościach wtyczki Yoast :D.

  • A tego nie wiedziałam, muszę sprawdzić, powinno pomóc na moje miniaturkowe dolegliwości. 🙂

  • U mnie ostatnio zaczęły się problemy z zaciąganiem linków do postów. Strona służbowa, zrobiona przez informatyka, wszystkie og:cośtam ustawione, wtyczka Yoast zainstalowana. Teraz po publikacji na Facebooku, po wklejeniu linku, powstaje tylko “goły” link do strony głównej, bez obrazka. Ustawienia Yoast dla konkretnego wpisu nie pomogły, debugger nie widzi obrazka ani tytułu.
    Problem zaczął się niedawno, poprzednie posty ładowały się bez problemu – zaciągało obrazek, tytuł, początek treści (lub ustawiony tekst). Po ponownym zdebugowaniu postu sprzed paru miesięcy, debugger widzi tylko obrazek, ale zamiast tytułu i treści znów pozostaje link do strony głównej.

    Jakieś pomysły?

    • To rzeczywiście jakiś chochlik. Dołącz do mojej grupy na FB i tam o tym pogadamy.

    • Mam ten sam problem, jakieś rozwiązania udało się znaleźć?

  • Przydatny wpis. Nie mam żadnych problemów z miniaturkami i linkami. Mam wtyczkę Yoast, wykonuję debug i wszystko jest prawidłowo. Jedyne co zauważyłem to przycisk ‘Scrape Again’ nie zawsze działa prawidłowo. Wtedy klikam na samym dole strony ‘Open Graph Object Debugger’ i w nowym oknie wybieram ‘Fetch new scrape information’. https://uploads.disquscdn.com/images/212e389f0287d256426518acecd207542739688900f8dbda240673e9a18860a9.jpg

  • Jeden szkopuł – autorka nawet się nie zająknęła, że chodzi tu o wtyczkę Yoast SEO w wersji PRO.

    • Nie zająknęła się …bo nie chodzi o wtyczkę w wersji PRO ;p
      -Yoast w wersji podstawowej ma wszystko, czego potrzeba.
      Może masz po prostu ukryte opcje zaawansowane (domyślnie) ?
      SEO >> Funkcjonalności >> Strony z zaawansowanymi ustawieniami => Włączone => Zapisz zmiany.

    • @disqus_dxe61sl4BX:disqus , oczywiście, że nie jest potrzebna wersja PRO – wystarczy włączyć w Yoast SEO zaawansowane ustawienia w SEO – Funkcjonalności – Strony z zaawansowanymi ustawieniami 🙂

      • https://uploads.disquscdn.com/images/7ccbdc69698d22aa3ad3b2a5687135fac372d914a804b02d67203bab5d7df4d6.png

        Pierwszy raz robię stronę, więc z góry przepraszam za pytanie. Wszystko zrobiłam wg instrukcji ale nie działa. Czy mam jeszcze zrobić “Dodaj znacznik meta Open Graph do sekcji witryny. Jest on używany przez Facebooka i inne serwisy społecznościowe podczas udostępniania w nich Twojej witryny.”
        Jeśli tak, to gdzie i jak, bo błądzę jak dziecko w mgle. Proszę o pomoc.

        • Ok, możliwe, że Twój motyw nie dodał tego kodu do strony, będzie niestety konieczna modyfikacja w kodzie. Jeśli masz z tym problem to wchodź do grupy: olag.pl/grupa-fb – tam znajdziesz szybką pomoc 🙂

  • No w żaden sposób nie jestem w stanie dodać miniatur postów na fb. Każdą z tych możliwości testowałem, nie ma żadnych błędów przy debugowaniu i nadal nic z tego szare pole z konturem “ludzika”

    • Szare pole z konturem ludzika? A nie próbujesz czasem zmienić swojego awatara do profilu prywatnego?

  • Dzię-ku-ję! 🙂

  • Ola, uwielbiam cię <3 wszystko działa jak należy 😀 okazało się, że w yoast musiałam na dole podac jeszcze id aplikacji na facebooku 🙂

  • Ja mam ciut inny problem którego ta porada nie rozwiązuje, mianowicie kiedy udostępniam posty zawsze dodaje się ta sama miniaturka, co zrobić by każdy wpis miał swoją własną miniaturkę wybraną ze zdjęć z danego posta ?

  • Działa, dziękuję!:)

  • Ja mam problem z tym, że w przypadku linku do bloga (str. główna) nie ładuje mi zdjęcia, której jest podlinkowane w Yoast Seo społeczności – Facebook, strona główna, tylko do zdjęcia z ostatniego wpisu. I zupełnie nie wiem dlaczego tak się dzieje.

    • Hej Karolina, być może masz osobno stronę w dziale Strony? Jeśli tak to tam powinnaś dodać fotę w ustawieniach Yoast SEO.

  • super 🙂

  • Hej. Od niedawna prowadzę bloga. Nie miałam dotąd takich problemów. Każdy udostępniany na fb artykuł z bloga wyglądał tak jak powinien. Niestety od jakiegoś czasu wszystko stopniowo zaczyna się psuć 🙁 . Na początku przy publikacji artykułu pojawiała się miniaturka ze strony głównej ale mogłam to szybko zmienić. Teraz nie pojawia się żadne zdjęcie… Punkt po punkcie wykonałam wszystkie Twoje rady. Nadal nic.. pomocy!

  • Super, problem naprawiony

  • Hej mam bloga na wordpress com ,narazie darmowy ,od jakiegos czasu mi nie udostepnia postow na fb i nawet gdy chce wkleic to fb nie pobiera adresu url,wg twojej instrukcji wyszzlo na to ze cos nie tak jest ze standardami. Tzn ze ktos zglosil moja strone?i mi zabloowali chocuaz nic zlego tam nie ma

    • Hej, niestety obawiam się, że z WordPress.com nie pomogę, bo to ograniczone rozwiązanie na wielu płaszczyznach jest. Możesz spróbować pisać w tej sprawie do WordPress.com, ale nie wiem czy to da jakiś efekt 🙁

  • Mam link do fanpage na facebooku z powyzszym problemem. Niestety sharing debugger od facebooka nie wykrywa błędu. Czy jest jeszcze jakis sposób, aby problem naprawić?

  • U mnie to jest jeszcze jakiś inny problem, miesiąc temu działało ładowanie grafik na FB czy pinterest obecnie ładuje się puste pole. Nie wiem co jest nie tak.

  • Obecnie u mnie wczytuje zawsze zły obrazek, nie ten jaki jest w wpisie tylko jakiś domyślny. Tak jest o długiego czasu to widać coś musiało się zmienić w samym FB.

  • Podmieniłem zdjęcie, które ma się wyświetlać wraz z linkiem do strony podanym na fb. Zmian dokonałem oczywiście we wtyczce YOAST. I niestety, ciągle jest stare zdjęcie – choć w podglądzie na stronie w konfiguracji wtyczki jest już dobrze. W czym może być problem?

Zostaw odpowiedź

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *